Echoes Corsac.net - Echoes camshot
samedi 04 avril 2009 (1 post)

Following the ACCEPT on packages on NEW during my vacations and the ack from the release team, I've just uploaded all Xfce 4.6 packages to unstable. Packages for your architectures should arrive on your mirror along the weekend.

the NEWS.Debian (which will be displayed if you use apt-listchanges (which is a good idea)) will warn you about some upgrade precautions to take. I'm reproducing it here:

xfce4 (4.6.0.1) unstable; urgency=low

  Xfce 4.6 includes multiple changes which are not directly visible to the
  user but might cause problems in rare cases.

  Settings management have been moved from the old MCS Manager to the xfconf
  system. User settings will be migrated automatically at first Xfce 4.6
  startup using the /usr/lib/xfce4/xfconf-migration/xfconf-migration-4.6.pl
  script contained in xfce4-utils. Once those settings have been migrated,
  the automatic run will be disabled but the script will stay (for future
  users).

  Menus are now managed using a dedicated library, used by various Xfce
  components (including xfdesktop4 and the menu panel plugin). This library
  tries to support the freedesktop.org specifications, but is not totally
  complete and thus lacks the support for some items, like .
  This renders useless the menu editor previously shipped with Xfce 4.4.
  Solutions for menu editing can be found at the following address:
  http://wiki.xfce.org/howto/customize-menu

  As the upgrade is pretty invasive, it is recommended to quit Xfce before
  doing so, but it's not required and upgrades have been made from the
  desktop environment without problems. In that case, be sure to quit Xfce
  not long after the upgrade.

 -- Yves-Alexis Perez <corsac@debian.org>  Thu, 02 Apr 2009 21:19:53 +0200

The xfce4-goodies will be updated soon to match the new goodies present for Xfce 4.6, and the desktop task (the “standard” install when you choose desktop=xfce in the installer) will be updated too (there's an ongoing discussion on pkg-xfce mailing list to select which packages should be part of that install).

Have a good upgrade!

Corsac@16:10:40 (Debian)

Images
Stats
  • 1512 posts
  • 6243 jours
  • 0.24 posts/jour
  • IRC
  • Last.fm
Stuff
Gallery
Tech
Webcomics
Weblogs
Desktop